Exim 远程代码执行漏洞(CVE-2019-15846)

综述

近日,Linux的邮件传输代理Exim被曝出存在一个远程代码执行漏洞(CVE-2019-15846)。当受影响版本的Exim服务器接受TLS连接时,可能会受此漏洞影响,导致被远程未经身份验证的攻击者以root权限执行任意代码。虽然默认的Exim配置文件没有启用TLS,但是,大多数企业都需要启用TLS来处理网络流量。
据官方提供的安全报告称,该漏洞可通过在初始TLS握手期间发送一个以“\0”结尾的SNI 来触发。
Exim维护者表示已经存在针对CVE-2019-15846的PoC,不过暂无发现野外利用。
CVSS:3.0 Base 9.8
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

参考链接:

http://exim.org/static/doc/security/CVE-2019-15846.txthttps://access.redhat.com/security/cve/cve-2019-15846https://threatpost.com/critical-exim-flaw-opens-millions-of-servers-to-takeover/148108/

受影响版本

  • Exim Version < 4.92.2

不受影响版本

  • Exim Version == 4.92.2

解决方案

Exim官方已在4.92.2版本中修复了该漏洞,请受影响的用户尽快采取措施进行防护,官方下载链接:https://exim.org/index.html
官方还提供了禁用 TLS 的缓解措施,但是强烈建议不要这样做。

还可向邮件访问控制列表(ACL)添加特定规则来阻止攻击,详见 https://lists.exim.org/lurker/message/20190906.111406.b0cb2d70.en.html
Ubuntu和Debian已经发布了更新的发行版或Exim包。所有生产版本的cPanel和WHM也已打补丁。详见https://usn.ubuntu.com/4124-1/、https://www.debian.org/security/2019/dsa-4517、https://documentation.cpanel.net/display/CKB/CVE-2019-15846+Exim


发表评论

评论已关闭。

相关文章